Как посчитать количество цифр в числе с
Перейти к содержимому

Как посчитать количество цифр в числе с

  • автор:

Как посчитать количество цифр в числе (число начинается на ноль)

Просто потому что если читать не строку, а число — то введете вы 00094 или 94 — в вашем x будет одно и то же число.

Отслеживать
ответ дан 12 дек 2019 в 14:36
222k 15 15 золотых знаков 120 120 серебряных знаков 234 234 бронзовых знака

А как тогда после из него «взять» первую, вторую и последующие цифры? Мне вот например нужно чтобы цифры на парных местах додавались, на непарных перемножались и этого всего найти суму.

12 дек 2019 в 14:42

x[0] — первая цифра (как символ! чтобы получить ее числовое значение, нужно вычитать символ ноля — x[0]-‘0’ ), x[1] — вторая и так далее.

Найти количество цифр в числе

Author24 — интернет-сервис помощи студентам

уважаемые эксперты подскажите в чем проблема. начал изучать язык С и надо было переписать программу которая встречалась в паскале с использованием рекурсии. Переписал, а что то видимо не так сделал. вот два кода подскажите пожалуйста в чем ошибка

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37
uses crt; var m:integer; n:longint; function schet(n:longint; var m:integer):integer; begin if n div 10 = 0 then begin inc(m); schet:=m; end else begin n:=n div 10; inc(m); schet:=schet(n,m); end; end; procedure input_data(var n:longint); begin writeln('Введите число:'); readln(n); end; procedure output_data(schet:integer); begin writeln('Количество цифр в введенном вами числе: ', schet); readkey; end; begin clrscr; writeln('Данная программа считает количество цифр в введенном пользователем числе.'); input_data(n); output_data(schet(n,m)); end.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
#include #include int schet(int n, int m) { if((n%10)==0) { m++; schet==m; } else { n=n%10; m++; schet==schet(n,m); } return schet; }; void main() { clrscr(); int n,m; printf("Введите число: "); scanf("%d", &n); schet(n,m); printf("Количество цифр в введенном вами числе: %d", schet); getch(); }

вычисление количества цифр целого введенного числа

Программа вычисляет количество цифр введенного числа. Вводим число (например 123), что же происходит дальше. Выражение num1/=10; делит число на 10 (123/10=12, дробная часть отбрасывается), произошла одна итерация, опять делит число на 10 (12/10=1, дробная часть отбрасывается), произошла вторая итерация. Опять делит число на 10 (1/10=0, дробная часть отбрасывается), произошла третья итерация. 0,1 не делит, так как переменная имеет целочисленный тип. Поэтому, на самом деле выводится не количество цифр, а количество итераций. Если ввести вещественное число (например 12,35), получится 47 итераций.

Как посчитать количество цифр в числе с

(0) строкачисла=Стрзаменить(строка(Число));//»123456″
колвоЦифр=0;
ДЛя каждого символ из строкачисла цикл
Если символ=»0″ тогда//(или 2-9)
колвоЦифр=колвоЦифр+1;
КонецЕсли;
КонецЦикла;

(7) Стрзаменить(строка(Число),» «,»»)*

(8)
строкачисла=Стрзаменить(строка(Число),» «,»»);//»123456″

колвоЦифр=0;
ДЛя каждого символ из строкачисла цикл
Если символ=»0″ тогда//(или 2-9)

колвоЦифр=колвоЦифр+1;
КонецЕсли;
КонецЦикла;

Форма.Форма.Форма(115)>: Итератор для значения не определен
ДЛя каждого символ из строкачисла цикл

(9) ну для символ=1 по СтрДлина(строкачисла) цикл
Если сред(строкачисла,символ,1)=»0″ тогда//(или 2-9)

реквизит значений тип Число

(11) и да
Если сред(строкачисла,символ,1)=»0″ или сред(строкачисла,символ,1)=»1″или сред(строкачисла,символ,1)=»2″. или сред(строкачисла,символ,1)=»9″тогда
колвоцыфр=колвоцифр+1;
КонецЕсли;

в (6) решение чем не устраивает?
(13) Потому что это конкурс )))
(13) не прочел)))))))
(14)У кого длиннее?
(16) а Фдрук там кроме цифор исчо чето написано?))
(17)ТС утверждает, что там число

(12)
строкачисла=Стрзаменить(строка(Число),» «,»»);//»123456″

колвоЦифр=0;
для символ=1 по СтрДлина(строкачисла) цикл

Если сред(строкачисла,символ,1)=»0″ или сред(строкачисла,символ,1)=»1″
или сред(строкачисла,символ,1)=»2″ или сред(строкачисла,символ,1)=»3″
или сред(строкачисла,символ,1)=»4″ или сред(строкачисла,символ,1)=»5″
или сред(строкачисла,символ,1)=»6″ или сред(строкачисла,символ,1)=»7″
или сред(строкачисла,символ,1)=»8″ или сред(строкачисла,символ,1)=»9″ тогда
колвоЦифр=колвоЦифр+1;
КонецЕсли;

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *