Значение данного типа невозможно преобразовать для передачи как файл
Перейти к содержимому

Значение данного типа невозможно преобразовать для передачи как файл

  • автор:

Значение данного типа невозможно преобразовать для передачи как файл

Есть файловая база Бухни 3.0 на управляемых, в карточки договоров контрагентов в прошлом году прикрепили под две сотни сканов, сегодня они все почему-то перестали открываться выдается ошибка «Ошибка при выполнении файловой операции. /e1cib/tempstorage/. /Значение данного типа невозможно преобразовать для передачи как файл.(Неопределено)». Конфа на замке.
При чем если сегодня загружать сканы то они все нормально открываются . Как исправить?

Потёрлись каким-то образом.
Поднять архив, загрузить их оттуда заново
Архив никто и некогда не делал:)))))))
. и полетели в автора темы помидоры)))
(2) кто бы сомневался

если уж яйца по 9-ть штук стали продавать то какие нафиг помидоры зимой ))) нефиг нефиг , пусть сам покупает

(0) А там где-нибудь случайно нет настройки где хранить эти сканы — в базе / в папках на диске. Например, раньше было на диске, потом переключили на базу, а там ведь пусто.

Значение данного типа невозможно преобразовать для передачи как файл

Нужно скопировать все файлы из всей номенклатуры в табличной части и прикрепить их к документу (этому же).

При копировании меняю родителя файла на документ, остальные поля без изменения.

Файлы копируются, но выдается ошибка при попытке предпросмотра.
Пытался скопировать простую картинку. Со стороны пользователя, крепится без всяких косяков, значит что-то не так делаю в коде.

Текст ошибки:
Ошибка при выполнении файловой операции ‘/e1cib/tempstorage/a0833b85-9030-4bcf-a474-d89989e67807’. Значение данного типа невозможно преобразовать для передачи как файл. (Неопределено)

&НаСервере
Процедура СкопироватьФайлыСервер()
Для Каждого Строка из Объект.Запасы Цикл

Запрос = Новый Запрос;
Запрос.Текст =
«ВЫБРАТЬ
| НоменклатураПрисоединенныеФайлы.Автор,
| НоменклатураПрисоединенныеФайлы.ВладелецФайла,
| НоменклатураПрисоединенныеФайлы.ДатаМодификацииУниверсальная,
| НоменклатураПрисоединенныеФайлы.ДатаСоздания,
| НоменклатураПрисоединенныеФайлы.Зашифрован,
| НоменклатураПрисоединенныеФайлы.Изменил,
| НоменклатураПрисоединенныеФайлы.ИндексКартинки,
| НоменклатураПрисоединенныеФайлы.Описание,
| НоменклатураПрисоединенныеФайлы.ПодписанЭП,
| НоменклатураПрисоединенныеФайлы.ПутьКФайлу,
| НоменклатураПрисоединенныеФайлы.Размер,
| НоменклатураПрисоединенныеФайлы.Расширение,
| НоменклатураПрисоединенныеФайлы.Редактирует,
| НоменклатураПрисоединенныеФайлы.СтатусИзвлеченияТекста,
| НоменклатураПрисоединенныеФайлы.ТекстХранилище,
| НоменклатураПрисоединенныеФайлы.ТипХраненияФайла,
| НоменклатураПрисоединенныеФайлы.Том,
| НоменклатураПрисоединенныеФайлы.ФайлХранилище,
| НоменклатураПрисоединенныеФайлы.Наименование
|ИЗ
| Справочник.НоменклатураПрисоединенныеФайлы КАК НоменклатураПрисоединенныеФайлы
|ГДЕ
| НоменклатураПрисоединенныеФайлы.ВладелецФайла В(&ВладелецФайла)»;

Пока Выборка.Следующий() Цикл
Спр = Справочники.ЗаказПокупателяПрисоединенныеФайлы.СоздатьЭлемент();
Спр.Наименование = Выборка.Наименование;
Спр.Автор = Выборка.Автор;
Спр.ВладелецФайла = Объект.Ссылка;
Спр.ДатаМодификацииУниверсальная = Выборка.ДатаМодификацииУниверсальная;
Спр.ДатаСоздания = Выборка.ДатаСоздания;
Спр.Зашифрован = Выборка.Зашифрован;
Спр.Изменил = Выборка.Изменил;
Спр.ИндексКартинки = Выборка.ИндексКартинки;
Спр.Описание = Выборка.Описание;
Спр.ПодписанЭП = Выборка.ПодписанЭП;
Спр.ПутьКФайлу = Выборка.ПутьКФайлу;
Спр.Размер = Выборка.Размер;
Спр.Расширение = Выборка.Расширение;
Спр.Редактирует = Выборка.Редактирует;
Спр.СтатусИзвлеченияТекста = Выборка.СтатусИзвлеченияТекста;
Спр.ТекстХранилище = Выборка.ТекстХранилище;
Спр.ТипХраненияФайла = Выборка.ТипХраненияФайла;
Спр.Том = Выборка.Том;
Спр.ФайлХранилище = Выборка.ФайлХранилище;
Спр.Записать();
КонецЦикла;
КонецЦикла;
КонецПроцедуры

1С:Предприятие 8

Типовая конфигурация
1С:Документооборот 8 КОРП. Антикризис, редакция 2.1

Версия 2.1.21

Новое в версии 2.1.21.12

  • Работа по технологии 1С:Облачная подсистема Фреш
  • Согласование заявок на оплату
  • Каналы обсуждений
  • Новые возможности списка «Задачи мне»
  • Процессы и задачи по файлам
  • Учет электронных документов
  • Новые возможности для учета документов в разрезе проектов
  • Автоматическая отправка проектных задач на исполнение
  • Развитие мобильного приложения
  • Развитие мобильного клиента (ознакомительная версия)
  • Исправлены ошибки:
    • При удалении ЭП в файлах документа появлялись служебные файлы.
    • При удалении ЭП штамп ЭП не удалялся из документа.
    • Если сервер на Linux, добавление файлов в том могло давать ошибку «the file name you specified is not valid or too long».
    • В веб-клиенте возникала ошибка при выполнении задачи, если ее предметом были занятые на редактирование файлы.
    • При настройке заполнения полей шаблона документа, при выборе параметра «На что заменять», возникала ошибка: Поле не найдено «ВидыКонтактнойИнформации.
    • Если в карточке вида документа были занятые файлы, нажатие на гиперссылку в колонке «Настройка заполнения» приводило к ошибке «Поле объекта не обнаружено (Расширение)».
    • Ошибка проверки заполнения доп. реквизита с условием по реквизитам процессов перед выполнением задачи.
    • Команда «Обсудить с участниками» отображалась в формах списков объектов.
    • Ошибка преобразования данных XDTO при обработке очереди обновления обсуждений.
    • При открытии файла картинки из карточки входящего ЭД возникала ошибка.
    • При подписании ЭП документа без права на изменение возникала ошибка «В данной транзакции уже происходили ошибки!».
    • При обновлении конфигурации, если не удалось установить монопольный режим, возникала ошибка «Слишком много фактических параметров».
    • При наборе текста в чате иногда пропадала часть текста.
    • Не очищался протокол выполнения задач по почте.
    • При выборе обязательного связанного документа не устанавливался фильтр по контрагенту, если по документу ведется «Учет сторон».
    • Автоматическая вставка штампа электронной подписи для pdf-файла более 10 страниц показывала их в неверном порядке.
    • В Протоколе работы сотрудников, если слева нет отображалось ни одного отдела, возникала ошибка «<(1, 1)>: Ожидается выражение «ВЫБРАТЬ»».
    • Для учетных записей почты с IMAP не велось полное удаление писем на email-сервере (они только помечались на удаление).
    • При выполнении команды «Напечатать » из встроенного просмотра картинок возникала ошибка: «Значение данного типа невозможно преобразовать для передачи как файл. (Неопределено)».
    • В карточке проекта в списке Документы отсутствовала команда «Показать удаленные».
    • Изменение наименования объекта должно менять тему авточата. Но если заголовок менялся вручную, изменение наименования не должно на него влиять.
    • Недостаточное количество символов для ввода наименования группы доступа физических лиц
    • Авточат «с нижестоящими» в некоторых сценариях мог оставаться после того, как из подразделения или рабочей группы были удалены все нижестоящие.
    • Команда «Обсуждение с участниками» не отображалась для группы «Все пользователи».
    • Обработка создания обсуждений – возникала ошибка в подсчете количества участников
    • Не сохранялся скрипт обработки при настройке комплексного процесса.
    • Автообновляемые обсуждения: не учитывалось делегирование при вычислении пользователей, имеющих права на добавление участников вручную.
    • В карточке исходящего письма встроенной почты после добавления получателей область «Адресаты» растягивалась на весь экран.

    Ошибка при сохранении файла документа в 1С

    Доработку делал по статье http://infostart.ru/public/408860/ Пожалуйста, помогите разобраться и исправить.

    Отслеживать
    12.3k 5 5 золотых знаков 29 29 серебряных знаков 40 40 бронзовых знаков
    задан 23 янв 2017 в 15:44
    user234409 user234409
    1 1 1 серебряный знак 3 3 бронзовых знака

    1 ответ 1

    Сортировка: Сброс на вариант по умолчанию

    Для наиболее точного ответа на вопрос необходимо указывать полную версию платформы 1С:Предприятие и, желательно, указать программный код в котором возникли проблемы.

    Ваша задача обычно решается таким кодом:

    &НаКлиенте Процедура ВыбратьФайл(Команда) НачатьПодключениеРасширенияРаботыСФайлами(Новый ОписаниеОповещения( "ОповещениеПодключенияРасширенияРаботыСФайлами", ЭтотОбъект)); КонецПроцедуры // ВыбратьФайл() &НаКлиенте Процедура ОповещениеПодключенияРасширенияРаботыСФайлами(Подключено, ДополнительныеПараметры) Экспорт Если Подключено Тогда Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие); Диалог.Заголовок = НСтр("ru='Выберите файл загрузки в формате (*.xls, *.xlsx, *.xml, *.csv, *.txt)'"); Диалог.ПолноеИмяФайла = ""; Диалог.МножественныйВыбор = Ложь; Диалог.ПредварительныйПросмотр = Истина; Диалог.Фильтр = "Формат (*.xls;*.xlsx;*.xml;*.csv;*.txt)|*.xls;*.xlsx;*.xml;*.csv;*.txt|"; Диалог.Показать(Новый ОписаниеОповещения("ОповещениеВыборФайла", ЭтотОбъект)); Иначе // Сообщить что не удалось подключить расширение КонецЕсли; КонецПроцедуры // ОповещениеПодключенияРасширенияРаботыСФайлами() &НаКлиенте Процедура ОповещениеВыборФайла(ВыбранныеФайлы, ДополнительныеПараметры) Экспорт Если ВыбранныеФайлы = Неопределено Тогда Возврат; КонецЕсли; Если ВыбранныеФайлы.Количество() = 1 Тогда НачатьПомещениеФайла(Новый ОписаниеОповещения("ОповещениеВыборФайлаНаСервере", ЭтотОбъект), , // Можно указать строковой реквизит тогда адрес будет так же в этом реквизите ВыбранныеФайлы[0], Ложь, УникальныйИдентификатор); Иначе // Сообщить что можно выбрать только один файл КонецЕсли; КонецПроцедуры // ОповещениеВыборФайла() &НаСервере Процедура ОповещениеВыборФайлаНаСервере(Результат, Адрес, ВыбранноеИмяФайла, ДополнительныеПараметры) Экспорт ПутьКФайлу = ПолучитьИмяВременногоФайла(); ДвоичныеДанные = ПолучитьИзВременногоХранилища(Адрес); ДвоичныеДанные.Записать(ПутьКФайлу); ТекстовыйДокумент = Новый ТекстовыйДокумент(); ТекстовыйДокумент.Прочитать(ПутьКФайлу); Содержимое = ТекстовыйДокумент.ПолучитьТекст(); УдалитьФайлы(ПутьКФайлу); КонецПроцедуры // ОповещениеВыборФайлаНаСервере() 

    P.S. Прикрепил ссылку на пример обработки.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *