Как посчитать сумму в 1с
Перейти к содержимому

Как посчитать сумму в 1с

  • автор:

Как рассчитать сумму в 1С?

Многим разработчикам 1С полезно уметь автоматизировать определенные процессы, подстраивая их под требования заказчика. Например, можно настроить программу таким образом, чтобы сумма в таблицах вычислялась автоматически при редактировании данных в других блоках (количество, цена за единицу и т.д.).

Чтобы сделать что-то похожее, необходимо произвести несколько простых действий. В частности, открыть конфигуратор, открыть форму нужного документа.

Как рассчитать сумму в 1С?

Как рассчитать сумму в 1С?

Далее нужно создать обработчик события «ПриИзменении» для колонок «Цена» и «Количество». Это можно сделать двумя способами.

  1. Правой кнопкой мыши вызвать меню колонки и выбрать обработчик во вкладке «События»:

Как рассчитать сумму в 1С?

  1. Создать обработчик в свойствах (нажать на лупу возле обработчика «ПриИзменении»)

Как рассчитать сумму в 1С?

После этого нужно выбрать подходящую директиву выполнения обработки. В данном случае «На клиенте»:

Как рассчитать сумму в 1С?

Откроется модуль формы с созданным обработчиком:

Как рассчитать сумму в 1С?

Далее требуется вписать следующий программный код:

То же самое нужно сделать и для колонки «Цена».

В переменную «СтрокаТабличнойЧасти» помещается текущая выделенная строка в табличной части (в которой меняется количество или цена товара). Для подсчета суммы необходимо обратиться к нужным реквизитам объекта («Количество» и «Цена») и перемножить их значения. Результат поместить в реквизит «Сумма».

Если данный процесс автоматического расчета нужен сразу для нескольких документов, можно внести вышеуказанный код в общий модуль. Например, процедуру «РассчитатьСумму» поместить в модуль «РаботаСДокументами». Если в модуле будут только функции, выполняемые на клиенте (обработки событий, связанные только с элементами формы), то в свойствах общего модуля нужно отметить «Клиент», чтобы к модулю можно было обратиться из функций с директивой «&НаКлиенте».

Как рассчитать сумму в 1С?

После имени процедуры «РассчитатьСумму» необходимо добавить «Экспорт», чтобы процедуру можно было вызвать из формы документа.

Данный код выглядит так:

Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт

Затем в модуле формы нужного документа следует создать обработчик события под названием «ПриИзменении» для колонок «Количество» и «Цена», и вызвать процедуру «РассчитатьСумму» из общего модуля.

Как посчитать сумму в «1С»?

В короткой статье мы расскажем, как в «1С» посчитать сумму чисел быстрее, чем на калькуляторе. Эти знания пригодятся вам при взаимодействии с интерфейсом «1С» и позволят экономить время.

В короткой статье мы расскажем, как в «1С» посчитать сумму чисел быстрее, чем на калькуляторе. Эти знания пригодятся вам при взаимодействии с интерфейсом «1С» и позволят экономить время.

Этот лайфхак «1С» поможет посчитать сумму чисел быстрее, чем на калькуляторе. В нашем примере мы зашли в оборотно-сальдовую ведомость раздела «Отчеты – Оборотно-сальдовая ведомость». Выделим ячейки, которые хотим суммировать. Программа сложила нужные значения, итоговая сумма отображается в правом верхнем углу в окне ∑ (рис.1).

Рис.1. Сложение чисел без калькулятора в «1С»

Этот прием вы можете использовать в любых отчетах и документах с любыми числовыми колонками и табличными частями (сумма, количество и т.д.).

Помимо этого, вы можете выделить не все документы, а только нужные при помощи следующего способа:

  • зажмите на клавиатуре клавишу Ctrl;
  • левой кнопкой мыши выделите (или отмените выделение) нужных строк. Отметим, что выделять строки в этом случае следует только в пределах одной колонки, которую вам требуется суммировать.

Подведем итоги

В короткой статье мы рассказали о хитрости в «1С», о которой мало кто знает и использует в работе. Эти знания пригодятся вам при взаимодействии с интерфейсом «1С» и позволят экономить время.

Общий модуль расчета суммы

О том, как рассчитать сумму по строкам табличной части документа, рассказывают на всех курсах по 1С программированию, это одна из первых тем, в интернете на эту тему также очень много информации. В своих статьях я и рассказываю про самые элементарные вещи, но этот вопрос пропустил, так как думал, что это умеют делать все.

О том, как рассчитать сумму по строкам табличной части документа, рассказывают на всех курсах по 1С программированию, это одна из первых тем, в интернете на эту тему также очень много информации. В своих статьях я и рассказываю про самые элементарные вещи, но этот вопрос пропустил, так как думал, что это умеют делать все. Но недавно к одной из моих статей написали комментарий, в котором спросили, как не просто настроить автоматический подсчет суммы по строкам, а сделать это с помощью общего модуля, так как в конфигурации может быть много документов, в которых необходимо это делать, можно, конечно, написать в каждом документе (модуле документа) один и тот же код, но это не совсем правильно и профессионально.

Расчет суммы строк табличной части документа с помощью общего модуля

Давайте для начала посмотрим, как можно настроить автоматический расчет суммы по строкам табличной части. Для примера возьму вот такой документ поступления, у него есть ТЧ, в которой отображается «Количество» и «Цена» нам нужно, чтобы при изменении одного из этих полей производился перерасчет суммы. То же самое делаем и для события при изменении поля «Цена». Вот в принципе и все, общий модуль для расчета суммы строк табличной части готов, его нужно только вызывать из нужного места. Модуль

Процедура ИтогСуммы(СтрокаТЧ)Экспорт СтрокаТЧ.Всего=СтрокаТЧ.Цена*СтрокаТЧ.Количество; КонецПроцедуры
 &НаКлиенте Процедура МатериалыКоличествоПриИзменении(Элемент) СтрокаТЧ=Элементы.Материалы.ТекущиеДанные; РассчетСуммы.ИтогСуммы(СтрокаТЧ); КонецПроцедуры &НаКлиенте Процедура МатериалыЦенаПриИзменении(Элемент) СтрокаТЧ=Элементы.Материалы.ТекущиеДанные; РассчетСуммы.ИтогСуммы(СтрокаТЧ); КонецПроцедуры &НаКлиенте Процедура МатериалыМатериалыПриИзменении(Элемент) СтрокаТЧ=Элементы.Материалы.ТекущиеДанные; СтрокаТЧ.Цена= ПолучитьЦенуКомплектующих(СтрокаТЧ.Материалы) КонецПроцедуры &НаСервере Функция ПолучитьЦенуКомплектующих(Комплектующие) Возврат Комплектующие.Цена КонецФункции // ПолучитьЦенуКомплектующих() &НаСервере Функция ПолучитьЦенуМатериалов(Материалы) Возврат Материалы.Цена КонецФункции // ПолучитьЦенуМатериалов() 

Как посчитать сумму в 1с

Дата публикации 30.07.2021

Использован релиз 3.0.98

В любых стандартных отчетах программы можно просуммировать суммы в ячейках отчета. Поле для суммирования расположено в правой верхней части формы и обозначено знаком суммы (рис. 1).

Удерживая левую клавишу мыши, выделите диапазон ячеек – автоматически просуммируются суммы в ячейках выделенного диапазона (рис. 1).

Если необходимо просуммировать суммы в отдельных ячейках, отмечайте ячейки для суммирования, удерживая клавишу Ctrl (рис. 2).

Подпишитесь на новости

Не пропускайте последние новости — подпишитесь
на бесплатную рассылку сайта:

  • десятки экспертов ежедневно мониторят изменения законодательства и судебную практику;
  • рассылка бесплатная, независимо от наличия договора 1С:ИТС;
  • ваш e-mail не передается третьим лицам;

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *