1с не удалось открыть файл который присоединен к
Перейти к содержимому

1с не удалось открыть файл который присоединен к

  • автор:

1с не удалось открыть файл который присоединен к

БП 3.0.
Ранее в одной из баз был сделан перенос прикрепленных файлов в том на диске.
Сейчас пытаюсь перенести прикрепленные файлы из другой базы. Эта база на том же логическом диске, папку (том) создаю рядом с ранее созданным, что делал для другой базы. Все делаю как и раньше.
Однако файлы в базе исчезают, а в том не переносятся, когда кликаю из 1С то : «Не удалось открыть файл:
Договор .pdf
который присоединен к:
Присоединен к Договор : Договор от 22.03.2021
по причине: двоичные данные файла были удалены. Возможно, файл очищен как ненужный.
Обратитесь к администратору.»
И в самой папке (томе) тоже пусто.
Не могу понять причину.

Попробовал при настройке «хранение в томах» прикрепить файл. Этот файл появился в папке (томе).
Получается, что все разрешения на папку правильные, но не работает сам перенос.
Такое впечатление, что спотыкается на каком-то файле и дальше перенос не идет, а попутно грохаются все прикрепленные файлы.

позанудствую : почитайте правила форума

ОшибкаФайлНеНайденВХранилищеФайлов (БСП)

  • Ошибка файл не найден хранилище файлов. Возвращает стандартный текст ошибки.

    // Возвращает стандартный текст ошибки. Функция ОшибкаФайлНеНайденВХранилищеФайлов(ИмяФайла, ПоискВТоме = Истина, ВладелецФайла = "") Экспорт Если ПоискВТоме Тогда ТекстОшибки = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку( НСтр("ru = 'Не удалось открыть файл: |%1 |который присоединен к: |%2 |по причине: двоичные данные файла были удалены. Возможно, файл очищен как ненужный или удален антивирусной программой. |Обратитесь к администратору.'"), ИмяФайла, ВладелецФайла); Иначе ТекстОшибки = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку( НСтр("ru = 'Не удалось открыть файл: |%1 |который присоединен к: |%2 |по причине: двоичные данные файла были удалены. Возможно, файл очищен как ненужный. |Обратитесь к администратору.'"), ИмяФайла, ВладелецФайла); КонецЕсли; Возврат ТекстОшибки; КонецФункции /////////////////////////////////////////////////////////////////////////////////////////////////////// // Copyright (c) 2019, ООО 1С-Софт // Все права защищены. Эта программа и сопроводительные материалы предоставляются // в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0) // Текст лицензии доступен по ссылке: // https://creativecommons.org/licenses/by/4.0/legalcode ///////////////////////////////////////////////////////////////////////////////////////////////////////
    // Возвращает стандартный текст ошибки. Функция ОшибкаФайлНеНайденВХранилищеФайлов(ИмяФайла, ПоискВТоме = Истина, ВладелецФайла = "") Экспорт Если ПоискВТоме Тогда ТекстОшибки = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку( НСтр("ru = 'Не удалось открыть файл: |%1 |который присоединен к: |%2 |по причине: двоичные данные файла были удалены. Возможно, файл очищен как ненужный или удален антивирусной программой. |Обратитесь к администратору.'"), ИмяФайла, ВладелецФайла); Иначе ТекстОшибки = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку( НСтр("ru = 'Не удалось открыть файл: |%1 |который присоединен к: |%2 |по причине: двоичные данные файла были удалены. Возможно, файл очищен как ненужный. |Обратитесь к администратору.'"), ИмяФайла, ВладелецФайла); КонецЕсли; Возврат ТекстОшибки; КонецФункции /////////////////////////////////////////////////////////////////////////////////////////////////////// // Copyright (c) 2019, ООО 1С-Софт // Все права защищены. Эта программа и сопроводительные материалы предоставляются // в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0) // Текст лицензии доступен по ссылке: // https://creativecommons.org/licenses/by/4.0/legalcode ///////////////////////////////////////////////////////////////////////////////////////////////////////

    1с не удалось открыть файл который присоединен к

    Проблема следующая. Возникает ошибка при формировании печатной формы счета в который я вывожу картинку с печатью и подписями.
    Когда обработку с печатной формой я открываю через файл открыть, выбираю на форме счет, то все отрабатывается нормально — выводится печатная форма с картинками подписей и печатью. Эта же дополнительная печатная форма когда добавлена к конфигурации выдаёт ошибку при печати этого же счета. Параметры команды аналогичны.

    : Не удалось открыть файл:
    Подпись.png
    который присоединен к:
    Присоединен к Физическое лицо : Цыбукова Эльмира Акифовна
    по причине: двоичные данные файла были удалены. Возможно, файл очищен как ненужный или удален антивирусной программой.
    Обратитесь к администратору.
    ВызватьИсключение РаботаСФайламиСлужебныйКлиентСервер.ОшибкаФайлНеНайденВХранилищеФайлов(

    Возникает при отработке кода:

    Попытка
    Возврат Новый ДвоичныеДанные(ПолныйПуть);
    Исключение
    // Запись в журнал регистрации.
    СообщениеОбОшибке = ТекстОшибкиПриПолученииФайла(ИнформацияОбОшибке(), ПрисоединенныйФайл);
    ЗаписьЖурналаРегистрации(НСтр(«ru = ‘Файлы.Получение файла из тома'», ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
    УровеньЖурналаРегистрации.Ошибка,
    Метаданные.Справочники[ПрисоединенныйФайл.Метаданные().Имя],
    ПрисоединенныйФайл,
    СообщениеОбОшибке);

    ПредставлениеВладельцаФайла = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
    НСтр(«ru = ‘Присоединен к %1 : %2′»),
    Строка(ТипЗнч(ФайлОбъект.ВладелецФайла)),
    ФайлОбъект.ВладелецФайла);

    ВызватьИсключение РаботаСФайламиСлужебныйКлиентСервер.ОшибкаФайлНеНайденВХранилищеФайлов(
    ФайлОбъект.Наименование + «.» + ФайлОбъект.Расширение,
    ,
    ПредставлениеВладельцаФайла);

    Ошибку выдаёт Новый ДвоичныеДанные(ПолныйПуть). ПолныйПуть всегда в обоих случаях одинаков.

    Что это такое и что с этим делать?

    (0) Так в коде сначала проверь существует ли файл.
    Если его нет, то переменные среды выведи, чтобы посмотреть где код выполняется

    Не удалось распаковать пакет электронных документов. Не настроена связь с контрагентом

    Рис. 1.jpg

    Данная ошибка возникает в Текущих делах ЭДО при нажатии «Отправить и получить» и свидетельствует о том, что в папке «Распаковать» имеются пакеты электронных документов, автоматическая распаковка которых не была произведена из-за того, что настройка получения электронных документов находится не в состоянии «Присоединен» или отсутствует вовсе.

    Рис. 2.jpg

    Открыв соответствующий пакет электронных документов можно убедиться, что отсутствуют обязательные поля, необходимые для распаковки пакета и последующего корректного принятия к учету (идентификатор получателя, идентификатор отправителя, контрагент). Для заполнения этих полей в некоторых случаях необходимо наличие в информационной базе приглашения между участниками ЭДО по данному документу в статусе «Присоединен».

    Рис. 3.jpg

    Решение: Необходимо дождаться перевода приглашения в статус «Присоединен». После этого необходимые для распаковки данные автоматический будут заполнены, и пакет будет успешно распакован.

    Отслеживать статус приглашения можно либо в настройке получения электронных документов по этому контрагенту, либо на вкладке «Приглашения» Архива ЭДО.

    Если статус не меняется длительное время, это может быть вызвано наличием проблем при настройке роуминговой связи. Для решения вопроса в этом случае необходимо обратиться в техническую поддержку 1С-ЭДО.

    В случае если ошибка распаковки сопровождается сообщением о неполученных приглашениях, ограниченных датой запроса необходимо выполнить их загрузку.

    Рис. 4.jpg

    Для этого необходимо перейти в справочник «Организации», нажать «ЭДО – Учетные записи».

    Рис. 5.jpg

    Двойным нажатием мыши открыть соответствующую Учетную запись ЭДО.

    Рис. 6.jpg

    В открывшемся окне нажать «Ещё» и выбрать «Начальные даты запроса данных у оператора ЭДО».

    Рис. 7.jpg

    Начальную дату запроса приглашений у оператора ЭДО необходимо очисть, после чего нажать «Записать и закрыть». Затем вернуться в раздел Текущие дела ЭДО и нажать «Отправить и получить».

    С сервера оператора ЭДО в информационную базу будут загружены отсутствующие настройки, и документ успешно распакуется.

    Добавить комментарий

    Ваш адрес email не будет опубликован. Обязательные поля помечены *