Как обратиться к элементу таблицы значений 1с
Перейти к содержимому

Как обратиться к элементу таблицы значений 1с

  • автор:

Как обратиться к элементу таблицы значений 1с

Как обратиться к элементу строки таблицы значений?

(0) Элементы в справочниках, а в ТЗ столбцы и строки (с полями).

не поверишь:
СтрокаТЗ.Поле

(2) Краткость — сестра. ээээ . не помню кого Чехова вроде

Спасибо. Офигеть, это не приходило мне в голову. Пытался добраться до значения через стр.получить(имя), добрался через стр.получить(номер). А это не приходило в голову.

Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.

Как обратиться к элементу таблицы значений 1с

Есть таблица значений, в ней 2 реквизита (столбца), знаю как получить текущую строку, а как получить выбранный конкретный элемент в столбце ?

ТекущиеДанные

(1) А можно точнее, вот так получаю текущую строку.

(0) а не мог бы ты поточнее выразиться?:) то бишь тебе нужно получить значение конкретной ячейки? то бишь к примеру значение первого столбца второй строки?

Что-то не получается, с строкой проблем нет, а вот получить текущую выбранную ячейку не получается.
Элементы.СписокКонтрагентов.ТекущаяКолонка — не?

Я вот тоже банальную вещь «с наскоку» не мог понять, как сделать.
Перебираю все строки табличной части документа нормально. По каждой получаю ссылку на номенклатуру. А вот как текущую себе в обработку получить, не могу понять. Бросил пока это дело.

(6) Поле объекта не обнаружено (ТекущаяКолонка)

Вообще поле и выбранная строка в событии «Выбор» уже есть. И ещё есть нюансы.

Поле объекта не обнаружено (ТекущийЭлемент) , блин.

Процедура ТвояТаблицаВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)

Если Элемент.ТекущийЭлемент = Элементы.ТвояТаблицаТвоеПоле Тогда
Сообщить(«Выбрано нужное поле»);
КонецЕсли;

Кстати, а как спрятать код подкат?
(10) Так ты это на сервере выполняешь?
(10) Покажи код
(12) По событию мне не катит, мне отдельно по нажатию кнопки надо.

Картина маслом. По кнопке автор с контекстом тащится на сервер, где вспоминает, что ему нужна текущая колонка.

Как обратиться к элементу таблицы значений 1с

Описание:

Таблица значений — это несохраняемый в базе данных объект, который позволяет строить динамические наборы значений и манипулировать ими (добавлять, редактировать, удалять элементы, сортировать). Он может быть наполнен значениями любого типа, т.е. в одной таблице типы хранимых значений могут быть разными. Одним из примеров использования данного объекта может служить организация представления в форме списка элементов справочника, отобранных по сложному алгоритму.

Необходимо отметить, что таблица значений, связанная с элементом управления ТабличноеПоле, будет иметь все колонки, имеющиеся в табличном поле, с соответствующими именами. Кроме того, таблица значений может иметь также и собственные колонки, не отображаемые в табличном поле, при этом их имена должны отличаться от имен колонок табличного поля.

Элементы коллекции: СтрокаТаблицыЗначений

Для объекта доступен обход коллекции посредством оператора Для каждого … Из … Цикл. При обходе выбираются элементы коллекции.

Возможно обращение к элементу коллекции посредством оператора [. ]. В качестве аргумента передается индекс строки (нумерация с 0).

Свойства:

Индексы Содержит коллекцию индексов таблицы значений.
Колонки Содержит коллекцию колонок таблицы значений.

Методы:

Вставить (Индекс) Вставляет строку на позицию в таблице значений, соответствующую указанному индексу. Возвращает вставленную строку.
ВыбратьСтроку (Заголовок, НачальнаяСтрока) Вызывает модальное диалоговое окно для интерактивного выбора строки из таблицы значений. Возвращает выбранную строку или Неопределено, если пользователь отказался от выбора.
ВыгрузитьКолонку (Колонка) Создает массив и копирует в него значения, содержащиеся в колонке таблицы значений. Возвращает этот массив.
Добавить () Добавляет строку в конец таблицы значений. Возвращает добавленную строку.
ЗагрузитьКолонку (Массив, Колонка) Загружает колонку таблицы значений из массива значений.
ЗаполнитьЗначения (Значение, Колонки) Заполняет все строки таблицы значений указанным значением.
Индекс (Строка) Получает индекс строки в коллекции строк таблицы значений. Если не найдено, то возвращается -1.
Итог (Колонка) Суммирует значения всех строк в указанной колонке. Если в колонке установлен тип и он единственный, то при суммировании будет предприниматься попытка преобразования значения к типу Число. Если колонке не присвоены типы, то в процессе суммирования будут принимать участие только значения, имеющие тип Число, значения других типов будут игнорироваться. Если в колонке несколько типов и среди них есть тип Число, то в процессе суммирования будут принимать участие только значения, имеющие тип Число, значения других типов будут игнорироваться. Если в колонке несколько типов и среди них нет типа Число, то результатом будет значение Неопределено.
Количество () Получает количество строк таблицы значений.
Найти (Значение, Колонки) Осуществляет поиск значения в указанных колонках таблицы значений. Возвращает строку, в которой содержится искомое значение. Если значение не найдено, то возвращается значение Неопределено.
НайтиСтроки (ПараметрыОтбора) Осуществляет поиск строк таблицы значений, отвечающих заданным условиям поиска. Возвращает массив строк таблицы значений, соответствующих условиям поиска. Замечание! Массив хранит ссылки на строки таблицы значений, то есть при изменении строки в таблице, значение в массиве тоже будет измененным.
Очистить () Удаляет все строки таблицы значений. Структура колонок остается неизменной.
Получить (Индекс) Получает значение по индексу. Работает аналогично оператору [].
Свернуть (КолонкиГруппировок, КолонкиСуммирования) Осуществляет свертку таблицы значений по указанным колонкам группировки. Строки, у которых совпадают значения в колонках, указанных в первом параметре, сворачиваются в одну строку. Значения этих строк, хранящиеся в колонках, указанных во втором параметре, накапливаются. Важно! Списки колонок не должны пересекаться. Колонки, не вошедшие ни в один из списков колонок, после выполнения метода удаляются из таблицы значений.
Сдвинуть (Строка, Смещение) Сдвигает строку на указанное количество позиций.
Скопировать (Строки, Колонки) Если указаны строки и колонки, то только они будут скопированы. Если не указаны, то будет создана полная копия таблицы значений.
СкопироватьКолонки (Колонки) Создает таблицу значений с заданным списком колонок.
Сортировать (Колонки, ОбъектСравнения) Сортирует таблицу значений в соответствии с указанными правилами сортировки.
Удалить (Строка) Удаляет строку таблицы значений, где Строка — индекс или сама строка.

Конструктор:

Новый ТаблицаЗначений

Оглавление (нажмите, чтобы раскрыть)

  • Как создать таблицу значений
  • Как добавить колонки в таблицу значений
  • Как добавить строки в таблицу значений
  • Как добавить в таблицу значений колонку с описанием типа и заголовка
  • Как перечислить все строки в таблице значений
  • Как перечислить все колонки в таблице значений
  • Как выгрузить колонку таблицы значений в массив
  • Как заполнить значения в колонке для всех строк таблицы значений
  • Как в таблице значений посчитать итог по колонке
  • Как найти строку в таблице значений по значению
  • Как найти строку в таблице значений поиском значения в определенных колонках
  • Как искать в таблице значений неуникальные значения
  • Как сдвинуть строку таблицы значений
  • Как создать копию таблицы значений
  • Как создать копию таблицы значений по нужным колонкам
  • Как создать копию таблицы значений по отбору
  • Как свернуть таблицу значений по колонке
  • Как отсортировать таблицу значений по колонке
  • Как отсортировать таблицу значений по нескольким колонкам
  • Как удалить строку из таблицы значений
  • Как программно вывести таблицу значений на форму
  • Как программно вывести на форму результат запроса в виде таблицы значений
  • Скачать и выполнить эти примеры на компьютере
&НаСервере Процедура ВыполнитьКодНаСервере() /// Как создать таблицу значений в 1с 8.3, 8.2 // с таблицей значений можно работать только на сервере Таб = Новый ТаблицаЗначений; /// Как добавить колонки в таблицу значений в 1с 8.3, 8.2 Таб.Колонки.Добавить("Фрукт"); Таб.Колонки.Добавить("Цвет"); Таб.Колонки.Добавить("Вкус"); /// Как добавить строки в таблицу значений в 1с 8.3, 8.2 Стр = Таб.Добавить(); Стр.Фрукт = "Яблоко"; Стр.Цвет = "Зелёный"; Стр.Вкус = "Кислый"; Стр = Таб.Добавить(); Стр.Фрукт = "Банан"; Стр.Цвет = "Желтый"; Стр.Вкус = "Сладкий"; Стр = Таб.Добавить(); Стр.Фрукт = "Слива"; Стр.Цвет = "Синий"; Стр.Вкус = "Терпкий"; /// Как добавить в таблицу значений колонку с /// описанием типа и заголовка в 1с 8.3, 8.2 ОписаниеВеса = Новый ОписаниеТипов("Число", Новый КвалификаторыЧисла(12, 3)); Таб.Колонки.Добавить("ВесФрукта", ОписаниеВеса, "Вес фрукта"); Таб[0].ВесФрукта = 100.005; Таб[1].ВесФрукта = 60.010; Таб[2].ВесФрукта = 25.000; /// Как перечислить все строки в таблице значений в 1с 8.3, 8.2 Для Каждого Стр Из Таб Цикл Сообщить(Стр.Фрукт + " " + Стр.Цвет + " " + Стр.Вкус + " " + Стр.ВесФрукта); КонецЦикла; /// Как перечислить все колонки в таблице значений /// в 1с 8.3, 8.2 Для Каждого Колонка Из Таб.Колонки Цикл Сообщить(Колонка.Имя); КонецЦикла; /// Как выгрузить колонку таблицы значений в массив в 1с 8.3, 8.2 // выгрузка названий фруктов в массив МассивФруктов = Таб.ВыгрузитьКолонку("Фрукт"); // ничего не измениться, так как массив не менялся Таб.ЗагрузитьКолонку(МассивФруктов, "Фрукт"); /// Как заполнить значения в колонке для всех строк таблицы /// значений в 1с 8.3, 8.2 // обнулим вес во всех строках Таб.ЗаполнитьЗначения(0, "ВесФрукта"); // выставим новые веса Таб[0].ВесФрукта = 100; Таб[1].ВесФрукта = 60; Таб[2].ВесФрукта = 25; /// Как в таблице значений посчитать итог по колонке в 1с 8.3, 8.2 Сообщить(Таб.Итог("ВесФрукта")); // 185 /// Как найти строку в таблице значений по значению в 1с 8.3, 8.2 // найдём строчку с яблоком и покажем его цвет НайденнаяСтрока = Таб.Найти( "Яблоко" ); Если НайденнаяСтрока <> Неопределено Тогда Сообщить(НайденнаяСтрока.Цвет); // Зелёный КонецЕсли; /// Как найти строку в таблице значений поиском значения /// в определенных колонках в 1с 8.3, 8.2 // будем искать по слову "Кислый" в колонках вкус и цвет НайденнаяСтрока = Таб.Найти("Кислый", "Вкус, Цвет"); Если НайденнаяСтрока <> Неопределено Тогда Сообщить(НайденнаяСтрока.Фрукт); // Яблоко КонецЕсли; // добавим ещё один зелёный фрукт Стр = Таб.Добавить(); Стр.Фрукт = "Киви"; Стр.Цвет = "Зелёный"; Стр.Вкус = "Сладкий"; Стр.ВесФрукта = 30; /// Как искать в таблице значений неуникальные значения /// в 1с 8.3, 8.2 Отбор = Новый Структура; Отбор.Вставить("Цвет", "Зелёный"); Строки = Таб.НайтиСтроки(Отбор); Для Каждого Стр Из Строки Цикл Сообщить(Стр.Фрукт); // Яблоко Киви КонецЦикла; /// Как сдвинуть строку таблицы значений в 1с 8.3, 8.2 // сдвигаем первую строку на одну позицию вперёд Таб.Сдвинуть(0, 1); // и возвращаем обратно Таб.Сдвинуть(1, -1); /// Как создать копию таблицы значений в 1с 8.3, 8.2 // полная копия КопияТаб = Таб.Скопировать(); /// Как создать копию таблицы значений по нужным колонкам /// в 1с 8.3, 8.2 // только две колонки будет Фрукт и Цвет КопияТаб = Таб.СкопироватьКолонки("Фрукт, Цвет"); /// Как создать копию таблицы значений по отбору в 1с 8.3, 8.2 Отбор = Новый Структура; Отбор.Вставить("Фрукт", "Яблоко"); // таблица будет содержать только строчку с яблоком КопияТаб = Таб.Скопировать(Отбор); // таблица будет содержать цвет и вес яблока КопияТаб = Таб.Скопировать(Отбор, "Цвет, ВесФрукта"); /// Как свернуть таблицу значений по колонке в 1с 8.3, 8.2 // свернём по вкусу, просуммируем по весу Таб.Свернуть("Вкус", "ВесФрукта"); /// Как отсортировать таблицу значений по колонке в 1с 8.3, 8.2 Таб.Сортировать("ВесФрукта Возр"); /// Как отсортировать таблицу значений по нескольким колонкам /// в 1с 8.3, 8.2 Таб.Сортировать("ВесФрукта Возр, Вкус Убыв"); /// Как удалить строку из таблицы значений в 1с 8.3, 8.2 // по индексу или по значению Таб.Удалить(0); КонецПроцедуры /// Как программно вывести таблицу значений на /// форму в 1с 8.3, 8.2 // см. примеры использования этой функции ниже // ТабВКоде - таблица значений, созданная программно // ТабРеквизит - имя реквизита формы типа ТаблицаЗначений // ТабНаФорме - имя элемента формы, связанного с ТабРеквизит &НаСервере Процедура ВывестиТаблицуЗначенияВКодеВТаблицуНаФорме(ТабВКоде, ТабРеквизит, ТабНаФорме) // реквизит ТабРеквизит и соответствующий // ему элемент формы ТабНаФорме уже созданы // нами в визуальном режиме // 1. добавляем колонки из ТабВкоде в реквизит ТабРеквизит НовыеРеквизиты = Новый Массив; Для Каждого Колонка Из ТабВКоде.Колонки Цикл НовыеРеквизиты.Добавить( Новый РеквизитФормы( Колонка.Имя, Колонка.ТипЗначения, ТабРеквизит ) ); КонецЦикла; ИзменитьРеквизиты(НовыеРеквизиты); // 2. добавляем колонки из ТабВКоде в элемент ТабНаФорме Для Каждого Колонка Из ТабВКоде.Колонки Цикл НовыйЭлемент = Элементы.Добавить( ТабРеквизит + "_" + Колонка.Имя, Тип("ПолеФормы"), Элементы[ТабНаФорме] ); НовыйЭлемент.Вид = ВидПоляФормы.ПолеВвода; НовыйЭлемент.ПутьКДанным = ТабРеквизит + "." + Колонка.Имя; КонецЦикла; // 3. наконец, передаём данные из ТабВКоде в ТабРеквизит ЗначениеВРеквизитФормы(ТабВКоде, ТабРеквизит); // готово! КонецПроцедуры &НаСервере Процедура СоздатьТаблицуНаФормеНаСервере() // программно создаём таблицу значений ТабВКоде ТабВКоде = Новый ТаблицаЗначений; ОписаниеСтроки = Новый ОписаниеТипов("Строка"); ОписаниеВеса = Новый ОписаниеТипов("Число", Новый КвалификаторыЧисла(12, 3)); ТабВКоде.Колонки.Добавить("Фрукт", ОписаниеСтроки, "Имя фрукта"); ТабВКоде.Колонки.Добавить("Цвет", ОписаниеСтроки, "Цвет фрукта"); ТабВКоде.Колонки.Добавить("Вес", ОписаниеВеса, "Вес фрукта"); Стр = ТабВКоде.Добавить(); Стр.Фрукт = "Яблоко"; Стр.Цвет = "Зелёный"; Стр.Вес = 200; Стр = ТабВКоде.Добавить(); Стр.Фрукт = "Банан"; Стр.Цвет = "Желтый"; Стр.Вес = 150; ВывестиТаблицуЗначенияВКодеВТаблицуНаФорме(ТабВКоде, "ТабРеквизит1", "ТабНаФорме1"); КонецПроцедуры /// Как программно вывести на форму результат запроса /// в виде таблицы значений в 1с 8.3, 8.2 &НаСервере Процедура ВывестиНаФормуРезультатЗапросаНаСервере() Запрос = Новый Запрос; Запрос.Текст = "ВЫБРАТЬ | Товары.Ссылка, | Товары.ВерсияДанных, | Товары.ПометкаУдаления, | Товары.Код, | Товары.Наименование, | Товары.Цвет, | Товары.ЕдиницаИзмерений, | Товары.Предопределенный, | Товары.ИмяПредопределенныхДанных |ИЗ | Справочник.Товары КАК Товары"; РезультатЗапроса = Запрос.Выполнить(); ТабВКоде = РезультатЗапроса.Выгрузить(ОбходРезультатаЗапроса.Прямой); // функция ВывестиТаблицуЗначенияВКодеВТаблицуНаФорме определена выше ВывестиТаблицуЗначенияВКодеВТаблицуНаФорме(ТабВКоде, "ТабРеквизит2", "ТабНаФорме2"); КонецПроцедуры /// Скачать и выполнить эти примеры на компьютере

Таблица значений в языке 1С 8.3, 8.2 (в примерах)

С уважением, Владимир Милькин (преподаватель школы 1С программистов и разработчик обновлятора).

Таблица значений в 1С 8.3 на примерах

Таблица значений в 1С 8.3 позволяет строить динамические наборы значений. При этом каких-либо жестких ограничений на тип данных не накладывается. Таблица значений создается в памяти и не сохраняется в базе данных, имеет множество полезных возможностей и работает очень быстро.

Свойствами таблиц значений являются:

  • индексы (коллекция индексов таблицы значений)
  • колонки (коллекция колонок таблицы значений).

Элементом коллекции является строка таблицы значений. Но необходимо учитывать тот факт, что с таблицей значений можно работать только на сервере.

Работа с таблицей значений в 1С 8.3 на примерах

Создать новую таблицу значений

ТЗ = Новый ТаблицаЗначений; 

Добавить колонку в таблицу значений

ТЗ.Колонки.Добавить("Автомобиль"); ТЗ.Колонки.Добавить("Цвет"); ТЗ.Колонки.Добавить("Класс"); 

Добавить колонку с описанием типа

// Необходимо, чтобы колонка таблицы значения была строго типизировано ОписаниеВеса = Новый ОписаниеТипов("Число", Новый КвалификаторыЧисла(10, 0)); ТЗ.Колонки.Добавить("ВесАвтомобиля", ОписаниеВеса, "Вес Автомобиля"); 

Добавить строку в таблицу значений

НоваяСтрока = ТЗ.Добавить(); НоваяСтрока.Автомобиль = "Mitsubishi "; НоваяСтрока.Цвет = "Синий"; НоваяСтрока.Класс = "C класс"; НоваяСтрока.Вес = 1500; НоваяСтрока = ТЗ.Добавить(); НоваяСтрока.Автомобиль = "KIA"; НоваяСтрока.Цвет = "Зелёный"; НоваяСтрока.Класс = "A класс"; НоваяСтрока.Вес = 1800; НоваяСтрока = ТЗ.Добавить(); НоваяСтрока.Автомобиль = "BMW"; НоваяСтрока.Цвет = "Зелёный"; НоваяСтрока.Класс = "E класс"; НоваяСтрока.Вес = 2100; 

Заполнить строку значениями

//ДанныеДляЗаполнения - структура, стройка другой таблицы и т.п. //Метод сопоставляет имена свойств и заполнят по ним значение ЗаполнитьЗначенияСвойств(ТЗ.Добавить(), ДанныеДляЗаполнения); 

Вставить строку

//Метод вставляет в таблицу значения новую строку НоваяСтрока = ТЗ.Вставить(0); // Если нужно изменить значения не всех колонок, то можно использовать НоваяСтрока = ТЗ[0] НоваяСтрока.Автомобиль = "Mitsubishi "; НоваяСтрока.Цвет = "Белый"; НоваяСтрока.Класс = "C класс"; НоваяСтрока.Вес = 1500; 

Сортировка

//Сортирует таблицу значение по нужным колонкам и направлению сортировки
ТЗ.Сортировать(«Цвет Убыв, Вес Возр»);

Получить значение

//Предположим что в строке №1 хранится информация об автомобиле БМВ. //А цвет храниться в колонке №2 с именем "Цвет" //Задача - получить значение цвета из таблицы значений // //Если мы знаем номер строки и название свойства: ЦветБМВ = ТЗ[0].Цвет; //Если мы значем номер строки и колонки ЦветБМВ = ТЗ[0][1]; // * отсчет номера строк и колонок начинается с 0 

Удалить строку

//Удаляем строку №1 из таблицы значений ТЗ.Удалить(ТЗ[0]); //Удалить строки по условию можно с помощью перебора (см. Обход таблицы значений) 

Найти одну строку

//Позволяет найти одну строку в таблице значений. //Искать можно как по всем колонкам таблице ИскомаяСтрока = ТЗ.Найти("Синий"); //Так и по определенной колонке: ИскомаяСтрока = ТЗ.Найти("Синий", "Цвет"); //*Метод находит первую попавшуюся строку, если их несколько //Если строка не найдена, то вернет "Неопределено" 

Найти несколько строк

// Позволяет найти сразу несколько строк в таблице значений //Создаем структуру для отбора ОтборПоЗеленомуЦвету = Новый Структура(); ОтборПоЗеленомуЦвету.Вставить("Цвет","Зеленый"); //Получаем массив строк с зелеными машинами МассивСоСтроками = ТЗ.НайтиСтроки(ОтборПоЗеленомуЦвету); 

Свернуть таблицу значений

//Позволяет "свернуть" таблицу значений: //1С оставляет указанные колонки в первом параметре и суммирует по колонкам из второго параметра ТЗ.Свернуть("Товар", "Вес"); 

Скопировать таблицу

//Позволяет получить копию таблицы значений. НоваяТЗ = ТЗ.Скопировать(); //Если нужны только некоторые строки - нужно вставить массив таких строк в 1-ый параметр //Если нужны только некоторые колонки - нужно вставить их имена через запятую в 2-ый параметр 

Скопировать таблицу без данных

//Делает копию таблицы, но без строк. Только колонки НоваяТЗ = ТЗ.СкопироватьКолонки(); 

Узнать количество строк

Наша команда предоставляет услуги по консультированию, настройке и внедрению 1С.
Связаться с нами можно по телефону +7 499 350 29 00.
Услуги и цены можно увидеть по ссылке.
Будем рады помочь Вам!

Очистить

//Очищает таблицу значений от строк ТЗ.Очистить();

Обход таблицы значения

Обход коллекции с выбором элемента осуществляется с помощью цикла >, где оператор цикла Для предназначен для циклического повторения операторов, находящихся внутри конструкции, в данном случае таблицы значений. Так же можно обращаться к элементу коллекции посредством оператора [ ] ([аргумент]), где аргументом является индекс строки. Нумерация индексов строк начинается с нуля [0].

Прямой обход

Для Каждого Стр Из ТаблицаЗначений Цикл Сообщить(Стр.Номенклатура); КонецЦикла; 

Обратный обход таблицы (снизу вверх)

Чаще всего применяется для удаления строк в таблице.

//Товары - таблица значений, где необходимо удалить строки с "Сумма = 0" Сч=0; Пока СчТовары.Количество() Цикл ТекущаяСтрока=Товары[Сч]; Если ТекущаяСтрока.Сумма=0 Тогда Товары.Удалить(ТекущаяСтрока); Сч=Сч-1; КонецЕсли; Сч=Сч+1; КонецЦикла; 

Обход колонок

Можно перечислить все колонки в таблице значений в 1с 8.3 с помощю цикла >:

Для Каждого Колонка Из ТаблицаЗначений.Колонки Цикл Сообщить(Колонка.Имя); КонецЦикла; 

Превратить структуру в таблицу значений

//Есть структура: СтруктураЛогинПароль = Новый Структура; СтруктураЛогинПароль.Вставить("Логин", "root"); СтруктураЛогинПароль.Вставить("Пароль", "1s83.info"); //Создаем таблицу значений: ТЗ = Новый ТаблицаЗначений; ТЗ.Колонки.Добавить("Логин"); ТЗ.Колонки.Добавить("Пароль"); //"Превращаем" структуру в таблицу значений: Для Каждого ТекущийЭлемент из СтруктураЛогинПароль Цикл НовСтр=ТЗ.Добавить(); НовСтр.Логин = ТекущийЭлемент.Ключ; НовСтр.Пароль = ТекущийЭлемент.Значение; КонецЦикла; 
  • Создание внешней печатной формы для управляемого приложения в 1С 8.3
  • Создание внешнего отчета в 1С 8
  • Поиск и замена значений 1С
  • Загрузка в 1C из Excel

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *